| Logado como Visitante | Grupo "Visitantes" Está vendo: Forum | Domingo, 26/05/2024, 4:37 AM | RSS |
Anime Mugen


[ Novas Mensagens · Membros · Regras · Buscar · RSS ]
  • Página 1 de 1
  • 1
Duas dúvidas sobre criação de char.
MatheusData: Sábado, 11/06/2011, 9:17 PM | Mensagem # 1
Aprendiz
Grupo: Usuários
Mensagens: 65
Awards: 0
Reputação: 0
Status: Offline
1 - Como eu coloco som na animação do meu char ? Não tô conseguindo colocar som quando ele anda, da um soco, etc.

2 - Como eu ponho animação para quando meu char perde ? Tipo, no template elecbyte player quando eu insiro a animação no air, só funciona quando perde quando acaba o tempo, mas quando o char perde normalmente não funciona.


 
Phonix2000Data: Sábado, 11/06/2011, 9:48 PM | Mensagem # 2
Criador Iniciante
Grupo: Usuários
Mensagens: 323
Awards: 2
Reputação: 12
Status: Offline
Quote (Matheus)
1 - Como eu coloco som na animação do meu char ? Não tô conseguindo colocar som quando ele anda, da um soco, etc.

depois de criar o arquivo .SND e adicionar os sons nele, no state do golpe coloque isso:

Code

[State 0, PlaySnd]
type = PlaySnd
trigger1 = animelem = 1 ;só um exemplo vc pode usar o trigger que vc quiser.
value = 0,0                    ;coloque o número do son e do grupo (do snd) que vc quer.
volume = 100


Quote (Matheus)
2 - Como eu ponho animação para quando meu char perde ? Tipo, no template elecbyte player quando eu insiro a animação no air, só funciona quando perde quando acaba o tempo, mas quando o char perde normalmente não funciona.

que eu saiba animação de lose só em time over mesmo,
pq depois do player morre ele vai levanta e fazer uma animação de lose? tosco

Oks



 
MatheusData: Domingo, 12/06/2011, 9:51 AM | Mensagem # 3
Aprendiz
Grupo: Usuários
Mensagens: 65
Awards: 0
Reputação: 0
Status: Offline
Quote (Phonix2000)
depois de criar o arquivo .SND e adicionar os sons nele, no state do golpe coloque isso:

Não funfo :(
Quote (Phonix2000)
que eu saiba animação de lose só em time over mesmo,
pq depois do player morre ele vai levanta e fazer uma animação de lose? tosco

É q quando ele morre, continua em pé, aí eu iria colocar sprites dele caído e com um som.


 
Phonix2000Data: Domingo, 12/06/2011, 12:14 PM | Mensagem # 4
Criador Iniciante
Grupo: Usuários
Mensagens: 323
Awards: 2
Reputação: 12
Status: Offline
Quote (Matheus)
Não funfo :(

vc fez algo errado.
Quote (Matheus)
É q quando ele morre, continua em pé, aí eu iria colocar sprites dele caído e com um som.

assim ão as próprias sprites de hit de quando morre ¬¬ não tem nada a ver com lose



 
FMitData: Domingo, 12/06/2011, 12:37 PM | Mensagem # 5
Criador
Grupo: Usuários
Mensagens: 706
Awards: 3
Reputação: 18
Status: Offline
Quote (Matheus)
Não funfo :(

Quote (Phonix2000)
vc fez algo errado.

veja se o arquivo snd foi realmente criado e adicionado no def do personagem.

se não, re-faça.

se ainda sim não funcione
tente utilizar o o trigger
trigger1 = movecontact = 1
no playsnd no state do dano (no state onde tem o hitdef) no cns.
Quote (Matheus)
É q quando ele morre, continua em pé, aí eu iria colocar sprites dele caído e com um som.

grupo 5000.
no air, serve para ele cair, os nomes do begin actions te dão a informação de qual sprite você precisa usar e como usar
também ha uma explicação no DOCS do mugen.

dai você adiciona o common1.cns no seu char (esse arquivo fica no data do mugen)
e adicione o som no state onde a animação dele tomando o hit final (cujo não me recordo no momento)
do mesmo modo que fez da outra vez, mas dessa vez use o trigger
time = 0 ou animelem = 1

qualquer duvida poste.


 
Phonix2000Data: Domingo, 12/06/2011, 1:14 PM | Mensagem # 6
Criador Iniciante
Grupo: Usuários
Mensagens: 323
Awards: 2
Reputação: 12
Status: Offline
Quote (FMit)
e adicione o som no state onde a animação dele tomando o hit final (cujo não me recordo no momento)

No meu gazille coloquei isso no state -3 :

Code

[State -3, KO Sound]
type = PlaySnd
trigger1 = life = 0 && time = 1 && stateno = 5030
value = s0,0


Matheus, eu não coloquei lá em cima, mais tem que colocar o S antes do número e grupo do som (exemplo: s0,0)
pode ser por isso que da errado.

oks



 
MatheusData: Segunda, 13/06/2011, 5:55 PM | Mensagem # 7
Aprendiz
Grupo: Usuários
Mensagens: 65
Awards: 0
Reputação: 0
Status: Offline
FMit, Phonix2000, Valeu pela ajuda, achei o problema, vcs nem imaginam, quando eu salvei o def do meu personagem, o Fighter Factory pois um ; antes do nome do arquivo do som, e como vcs sabem, tudo depois do ; é ignorado pelo mugen, por isso não tava funcionando.
DÚVIDA RESOLVIDA = TÓPICO FECHADO


 
FMitData: Segunda, 13/06/2011, 6:05 PM | Mensagem # 8
Criador
Grupo: Usuários
Mensagens: 706
Awards: 3
Reputação: 18
Status: Offline
Quote (Matheus)
DÚVIDA RESOLVIDA = TÓPICO FECHADO

aprenderam né?


 
  • Página 1 de 1
  • 1
Buscar:

Copyright Anime Mugen © 2024 Hospedado por uCoz
Refresh Smileys Manager
Mini-chat